MacでマイクラのModサーバを立てるのであればJavaSDKはバージョン8でする必要があります。

 どうもこんにちは、新しいMacBookProでパソコン生活がバラ色な如月翔也(@showya_kiss)です。
 今日はWindowsで立てていたマイクラのModサーバをMacBookProに移行したんですが躓いた部分があるのでメモを。
 ForgeのJarファイルを拾ってきて開いたときにJDKが必要と表示され、その画面からJavaSDKのダウンロード画面に行けるのですが、「最新ならば良いだろう」と思ってバージョン12をダウンロードしてはいけません。サーバがエラーを吐いて起動しなくなります。
 必要なJDKのバージョンは8で、8の最新版をダウンロードしてきてセットアップ、それより新しいJDKは削除しておかないと起動しなくなります。

 間違えて他バージョンのSDKをインストールしてしまった場合はTerminalで「/usr/libexec/java_home -V」を実行、JDKのフォルダが表示されるので8以降のフォルダを記憶しておき、「sudo rm -rf フォルダのパス」でフォルダごと削除すれば一発です。

 バージョンが新しいと駄目だという発想はなかったのでトラブルシュートまで1時間くらいかかりましたが、気づけば一瞬でした。
 新しいパソコンに浮かれてなんでも大雑把にやってないで、ちゃんと気をつけて動かなければなりませんね……。

スポンサーリンク
レクタングル(大)




レクタングル(大)




シェアする

  • このエントリーをはてなブックマークに追加

フォローする

スポンサーリンク
レクタングル(大)